Speedometer error

Talk everything technical and new 500 here!
Post Reply
Egoldeng
Posts: 10
Joined: Sat Feb 09, 2013 6:52 pm

Speedometer error

Post by Egoldeng » Sat Feb 09, 2013 7:03 pm

Sorry if this topic has been covered in this forum but I cannot find it. Anyway , my new Pop 500 speedometer appears to be off in some way. The analog needle sitting on a perfect 60 miles and hour while the digital one reads a consistent 57. Anyone else see this on their cars or am I just the unlucky one? I guess I may need to find out which one is right. That is like around a 5 percent difference.

Egoldeng
Posts: 10
Joined: Sat Feb 09, 2013 6:52 pm

Re: Speedometer error

Post by Egoldeng » Fri Feb 22, 2013 12:50 pm

I noticed that when not moving and no key in car that the speedometer needle sits at about 2 to 3 mph above the zero line. I guess that accounts for the anolog reading higher than the digital on speed. Did not notice that before.

tikitackett
Posts: 4
Joined: Tue Nov 12, 2013 9:11 pm
Location: Orlando, Florida

Re: Speedometer error

Post by tikitackett » Tue Nov 12, 2013 9:14 pm

I noticed the same thing when I was driving my 500 Sport from Florida to Ohio last year.

I was going 73 according to the analog speedo, 70 according to the digital, and 68 according to the "Speed Limit: Your Speed" digital sign on the side of the road.

Ever since, I have been going off of the digital speedo, minus 2mph.

I asked my studio, and they were aware of the issue, but said there wasn't yet a "fix" for it.

Post Reply